2009年4月15日水曜日

WindowsにRailsをインストール

スズキです。

RubyGemsの次は、Railsです。
http://suz-lab.blogspot.com/2009/04/windowsrubygems.html

下記のようにRubyGemsを用いてインストールします。(簡単すぎです)

>gem install rails --include-dependencies
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
Successfully installed rake-0.8.4
Successfully installed activesupport-2.3.2
Successfully installed activerecord-2.3.2
Successfully installed actionpack-2.3.2
Successfully installed actionmailer-2.3.2
Successfully installed activeresource-2.3.2
Successfully installed rails-2.3.2
7 gems installed
Installing ri documentation for rake-0.8.4...
Installing ri documentation for activesupport-2.3.2...
Installing ri documentation for activerecord-2.3.2...
Installing ri documentation for actionpack-2.3.2...
Installing ri documentation for actionmailer-2.3.2...
Installing ri documentation for activeresource-2.3.2...
Installing RDoc documentation for rake-0.8.4...
Installing RDoc documentation for activesupport-2.3.2...
Installing RDoc documentation for activerecord-2.3.2...
Installing RDoc documentation for actionpack-2.3.2...
Installing RDoc documentation for actionmailer-2.3.2...

ここで注意点ですが、実際RubyGemsを利用するには、"zlib.dll"が必要になります。
下記の"zlib-1.1.4-1-mswin32.zip"をダウンロードして、
http://jarp.does.notwork.org/win32/
展開フォルダのbin下の"zlib.dll"をruby.exeと同じフォルダにコピーすればOKです。

※ zlib以外にもdllが別途必要になるものがあります。(下記にまとめられています)
http://www.garbagecollect.jp/ruby/mswin32/ja/documents/install.html

次は、ようやく、"redmine"だ!

--
http://suz-lab.blogspot.com/

0 コメント: