2010年4月5日月曜日

$VERSIONでエラー(Perlモジュール)

スズキです。

以下のようにPerlモジュールを作って実行してみると、
http://blog.suz-lab.com/2010/04/perl_05.html

次のようなエラーが発生してしまいました。
Global symbol "$VERSION" requires explicit package name at ...

こちらのドキュメントなどを見る限り、
http://search.cpan.org/~jpeacock/version-0.80/lib/version.pod

> use version; $VERSION = qv('0.0.1');

を以下のようにすれば、良いようです。(実際にうまくいきました)

> use version; our $VERSION = qv('0.0.1');

なんか、復活してきたぞ...

--------
http://www.suz-lab.com

0 コメント: